
cannot use the HTML view to embed your own form via HTML in the HTML editor. We recommend
you put the form on a page that is not stored in the program but can be referenced in an iFrame.
For more information about how to include customized forms in the program, contact Blackbaud’s
Professional Services at solutions@blackbaud.com.

• Preview – To view the content as it will appear on the web page and to test hyperlinks, click
Preview on the View tab in the toolbar. The Preview screen appears. To return to the normal view,
close the window.

HTMLEditor Functions
These tables explain the buttons and menus on the toolbar of the HTML editor. Some features have
more buttons available than others.

Note: On your website, users can use an HTML editor with a limited set of these buttons on some
parts. With the HTML editor, users can also insert images, tables, or links.

ButtonsandMenuson theToolbar
Show Me: Watch how to use the HTML editor ribbon toolbar.

Formatting Tab

Button Function Description

Cut To remove text from the content area and copy it to the clipboard, click Cut.
The text is removed, and you can paste it elsewhere in the content area.

Copy To copy text to the clipboard, click Copy. You can paste the text elsewhere in
the content area.

Paste To paste text from the clipboard to the content area, click Paste.

Font family
menu

This menu lists common fonts that appear on most web browsers. To
change the font applied to text, select a font.

Font size
menu

To change the size of text, select a size from this menu.

Insert
unordered
list

To insert a bulleted list, click Insert unordered list. The HTML editor adds an
<ul> tag at the selected location. The items in the list have bullets. To end a
list, click Insert unordered list again.

Insert
numbered
list

To insert a numbered list, click Insert numbered list. The HTML editor adds
an <ol> tag at the selected location. The items are numbered sequentially,
starting with “1.” To end a list, click Insert numbered list again.

11 CHAPTER 1

mailto:solutions@blackbaud.com
http://www.blackbaud.com/files/support/guides/demo/htmledit.aspx
















Menu Menu
name

Description

Size menu To change the size of text, select a size from this menu.

Paragraph
menu

To apply a paragraph tag to text, select a format from this
menu. For example, select “Normal” for body text.
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Merge Fields
To create personalized content, use merge fields to display offline information. For example, in an
email, you can insert the First name merge field so it displays “Hello, <First name>” to the recipient.
• To add merge fields, clickMerge fields on the Insert tab in the HTML editor toolbar. The merge
fields list appears in a separate window that you can move around.

• To view the available fields, click the plus sign next to a group of fields to expand the list.

• You can double-click or drag and drop merge fields from the window to the content area.

• You can add multiple fields at a time. To do this, place your cursor to the left or right of the group
name or fields (not over the group or fields) and click and drag your mouse to select them. After
the fields are selected, you can drag them as a group to the content area.

Style Sheet Options
On your website, the program uses the style sheet associated with a web page’s layout to render the
content you enter in the HTML editor. Because the part on which you enter the HTML content may be
shared across multiple web pages with different style sheets, you may need to edit the content as
necessary to improve its readability with a specific style sheet. When you use the HTML editor in the
normal view, you can view the content as it appears with different style sheets applied.

Note: Other styles, such as those applied to the containers of the part, may affect how the content
appears on the web page. To see how the HTML content ultimately appears on a specific web page,
we recommend you use Pages & templates. For information about Pages & templates, see the Website
Design Guide.
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View HTML content with a specific style sheet applied
1. On the View tab in the HTML editor toolbar for formatted text and images parts, click Style

sheet options. The Style sheet Options screen appears.

2. In the Edit using style sheet field, select the style sheet to apply to the content in the HTML
editor.

3. Depending on the style sheet, the background and foreground colors of the HTML editor may
affect the readability of your text. Change the background and foreground colors of the HTML
editor as necessary to edit the content.

a. Select Override style sheet colors.
b. Select the color to adjust. For the background color, click Select next to Editor background

color. For the foreground color, click Select next to Editor default font color.
The Select a color screen appears. Using the tabs, you can pick a color three different ways or
enter its hexadecimal value in the Color field.
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c. Click Apply. You return to the Style sheet Options screen.
4. Click OK. You return to the HTML editor. The content appears with the selected style sheet and

colors applied.

HTMLEditor Table and Line Properties
In the normal view, you can use the HTML editor to design tables, table rows, table cells, and
horizontal lines that divide the web page. You can also adjust the properties for these items to
determine characteristics such as size, styles, and color.

• To create a table, click Table on the Insert tab in the HTML editor toolbar. The Insert/Edit Table
Screen appears. On the General and Advanced tabs, you can design the table and adjust its
properties. We recommend only users familiar with HTML and CSS style elements adjust the
properties on the Advanced tab. For more information, seeInsert/Edit Table Screen on page
23Insert/Edit Table Screen on page 23.

• To edit the properties of a row in a table, select the row and click Row properties on the Table tab
in the toolbar. The Table Row Properties screen appears. On the General and Advanced tabs, you
can design the row and adjust its properties. We recommend only users familiar with HTML and
CSS style elements adjust the properties on these tabs. For more information, see Table Row
Properties Screen on page 25.

• To edit the properties of a cell in a table, select the cell and click Cell properties on the Table tab
in the toolbar. The Table Cell Properties screen appears. On the General and Advanced tabs, you
can design the cell and adjust its properties. We recommend only users familiar with HTML and
CSS style elements adjust the properties on these tabs. For more information, see Table Cell
Properties Screen on page 27.

• To insert a horizontal line, click Horizontal ruler on the Insert tab in the toolbar. On the screen that
appears, enter the width and height for the line and select whether to include a shadow.
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Insert/EditTableScreen
To create a table, click Table on the Insert tab in the HTML editor toolbar. The Insert/Edit Table Screen
appears. On the General and Advanced tabs, you can design the table and adjust its properties. We
recommend only users familiar with HTML and CSS style elements adjust the properties on the
Advanced tab. After you create a table, you can select the table and click Table to edit its properties.
General Tab

Screen Item Description

Cols Enter the number of columns.

Cellpadding Enter the amount of space to appear between the ruled line and the content of a cell in
the table.

Alignment Select the horizontal alignment of the table. You can select Left, Center, Right, or Not
Set.

Width Enter the pixel dimensions to use for the cells.

Class Select the CSS class to apply.

Table caption Select this checkbox to display a caption at the top of the table. To remove the table
caption, clear the checkbox or delete its code in HTMLmode.

Rows Enter the number of rows.
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Screen Item Description

Cellspacing Enter the amount of space to appear between cells of the table.

Border Enter the width, in pixels, of a border around the table. To display the table with no
border, enter “0.”

Height Enter the pixel dimensions to use for the cell.

Advanced Tab

Screen Item Description

ID Enter a unique identifier for the table.

Summary Enter a summary of the table, such as for speech-synthesizing or non-visual browsers.

Style Enter the CSS class to apply to the table.

Language code Enter the language code for text in the table, such as “en-US” for United States English.
This allows the browser to render content more meaningfully based on accepted
cultural practice for the specified language, such as applying correct punctuation and
assisting screen readers and search engines.

Background image To insert an image that appears as the background of the table or cell, click Browse to
open the Image library and select an image.
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Screen Item Description

Frame Select this checkbox to display a caption at the top of the table To remove the table
caption, clear the checkbox or delete its code in HTMLmode.

Rules Select which ruled lines appear between cells of the table. You can select to display all
lines, no lines, or only those between rows, columns, or groups.

Language direction Select the directionality for text in the table — left to right or right to left.

Border color Enter the color for the border of the table. You can enter the standard color name or
hexadecimal value, or click Browse to select the color from the palette.

Background color Enter the color for the background of the table. You can enter the standard color name
or hexadecimal value, or click Browse to select the color from the palette.

TableRowProperties Screen
To change the properties of rows in the table, select a row and click Row properties on the Table tab
in the HTML editor toolbar. The Table Row Properties screen appears. We recommend only users
familiar with HTML and CSS style elements adjust the properties on the Advanced tab.

Use the field at the bottom of the screen to select which rows to update with changes — the current
row, odd rows in the table, even rows in the table, or all rows in the table.

General Tab
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Screen Item Description

Row type Select Header, Body, or Footer for the row type.

Alignment Select the horizontal alignment of the row. You can select Left, Center, Right, or
Not Set.

Vertical alignment Select the vertical alignment of the row. You can select Top, Center, Bottom, or Not
Set.

Class Select the CSS class to apply to the row.

Height Enter the pixel dimensions to use for the row height.

Advanced Tab

Screen Item Description

ID Enter a unique identifier for the row.

Style Enter the CSS class to apply to the row.

Language direction Select the directionality for text in the row — left to right or right to left.

Language code Enter the language code for text in the row, such as “en-US” for United States English.
This allows the browser to render content more meaningfully based on accepted
cultural practice for the specified language, such as applying correct punctuation and
assisting screen readers and search engines.

Background image To insert an image that appears as the background of the row, click Browse to open
the Image library and select an image.
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Screen Item Description

Background color Enter the color for the background of the row. You can enter the standard color
name or hexadecimal value, or click Browse to select the color from the palette.

TableCell Properties Screen
To change the properties of cells in the table, select a cell and click Cell properties on the Table tab in
the HTML editor toolbar. The Table cell properties screen appears. We recommend only users familiar
with HTML and CSS style elements adjust the properties on the Advanced tab.

Use the field at the bottom of the screen to select which cells to update with changes — the current
cell, all cells in the row, all cells in the column, or all cells in the table.

General Tab

Screen Item Description

Alignment Select the horizontal alignment of the cells You can select Left, Center, Right, or Not
Set.

Vertical alignment Select the vertical alignment of the cells You can select Top, Center, or Bottom.

Width Enter the pixel dimensions to use for the cell width.

Class Select the CSS class to apply to the cell.

Cell type Select whether the cell is a header for a column or includes data.
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Screen Item Description

Scope Select whether the cell type applies to the column, row, group of columns, or group
of rows.

Height Enter the pixel dimensions to use for the cell height.

Advanced Tab

Screen Item Description

ID Enter a unique identifier for the cell.

Style Enter the CSS class to apply to the cell.

Language direction Select the directionality for text in the cell — left to right or right to left.

Language code Enter the language code for text in the cell, such as “en-US” for United States English.
This allows the browser to render content more meaningfully based on accepted
cultural practice for the specified language, such as applying correct punctuation and
assisting screen readers and search engines.

Background image To insert an image that appears as the background of the cell, click Browse to open
the Image library and select an image.

Border color Enter the color for the border of the cell. You can enter the standard color name or
hexadecimal value, or click Browse to select the color from the palette.

Background color Enter the color for the background of the cell. You can enter the standard color name
or hexadecimal value, or click Browse to select the color from the palette.
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SearchScreen
You may need to select data from the database to create parts for your website. For example, you can
select a constituent query to use to create a Directory part or an appeal for a Donation form on your
website. To help find and select data to use, the program provides a search screen specific to the type
data you need. On the Search screen, you can enter search criteria to help find the data. The criteria
options available depend on the type of data needed.

Note: If you are searching for a query, the Raiser’s Edge query types of constituent, gift, and job are
available in the program.

Use the search screen to select data
Search results that appear in the grid must match all the criteria you enter. We recommend you
search by one or two of the most helpful criteria types. If you enter too much criteria, you can
exclude the data you want.

1. On the search screen, enter the criteria to use to find the data. The criteria options available
depend on the type of data you need.

To search the database for all data of that type, leave the criteria fields empty.

2. Click Search. The program searches the database for data that meet the criteria entered and
displays the results in the grid.

3. If the search returns multiple pages of results, use the First, Previous, Next, and Last buttons
to navigate through the pages of results.

4. In the grid, find the data to use and click Select next to its listing. You return to the previous
screen.

Insert Image
From the HTML editor and several parts, such as the Navigation Buttons part, Weblog part, and User
Photos Form part, you can use the Insert image button to select an insert an image from the Image
Library.

Note: On your website, if the user clicks the Insert image button on the HTML editor, an Insert Image
screen appears. From this screen, the user can insert an image and load or edit existing images. You
can configure the user’s Image library, including image approval, on the Settings tab in Sites &
settings. For information about Image library, see the Website Design Guide.

Insert an image
1. On the Edit Part screen, click the Insert image button. The Select Image From Image library

screen appears.

2. On the Folders tab, you can select a folder to view its images.
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3. On the Search tab, you can search for images by name, tag, ID, image type, approval status, or
site. After you click Search, the images that meet your criteria appear in the grid.

4. To upload images to Image library, click Add images. Images must be *.bmp, *.gif, *.ico,
*.jpeg, *.jpg, or *.png files. For information about Image library, see the Website Design Guide.

5. In the grid, select an image and click Insert. You return to the previous screen.

CreatePage Link
From the HTML editor and several parts, such as the Formatted Text and Images and Menu parts, you
can create a hyperlink to a personal page, web page, or a document on your website. You can also link
to a web page version of an email message, or create links to desktop and mobile versions of your
content.

Note: On your website, if a user clicks the Insert link button on the HTML editor, an Insert Link screen
appears. From this screen, the user can add a link to another web page. If the user has a personal page
on your website, the user can also link to it.

Insert a link to a web page or document
1. On the Edit Part screen, click the Insert link button. The page link screen appears.
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Note: To access the page link screen from the HTML editor, such as on the Helplets tab or in Email,
click Insert link on the toolbar.

2. Select whether to create or remove a link from the part.
• To create a link to another page on your website, select Create link to Blackbaud
NetCommunity page and browse to the page to link. To link to a Blackbaud NetCommunity
page, you must have rights to view pages. For more information about view rights, see the
Users & Security Guide.

• To create a link to a page defined in Sites & settings, a web page version of an email message,
or a desktop or mobile version of your content, select Create link to special page. In the
Page field, select the option to link. The options that appear in this field generate in one of
three ways.
The home page, user login page, and privacy page you define in Sites & settings appear. For
more information, see the Administration Guide.

Note: In addition to the user login page you define in Sites & settings, additional user login pages
appear so you can select the password reset page on your website. When you include this page link
in email messages and an email recipient clicks the link, a secure page appears with a Forgotten
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Password field for the user to enter their email address. This link remains active in the email for the
user to take action to reset the password any time. After the email address is submitted on the web
page, another email sends to the user. That email contains another link that returns the user to the
reset password page on your website.

When you use the HTML editor to design an email message, the View email message on web
page option appears. Select this to provide a way for email recipients to view your email design
on a web page. You do not manually create the page the email message appears on and you
cannot open it in Pages & templates. The program automatically renders your HTML email
design to display the message and you can only access it from the link in the message.

Note: To test the link, send a test message. The link does not work when you preview the message.

When you design a layout, Menu part, or Formatted Text and Images part, the View desktop
version and View mobile version options appear. You can create links to one or both options to
allow users to toggle between the desktop and mobile versions of your content.

Note: To include a link to the mobile version of your content, you must first create a mobile
optimized layout and style sheet. For more information, see the Website Design Guide.

• To link to a specific location on the page, click Create link to an anchor in this document. In
the Anchor field, select the predefined anchor to link to. For information about how to insert
an anchor, see HTML Editor Functions on page 11.

• To create another type of link, select Create other type of link. In the Type field, select the
type of link to create. For example, select “ftp:,” “http:,” or “telnet.” In the URL field, enter the
exact path to the page to link.

• To create a link to a document on your website, such as an Adobe Acrobat portable document
file (*.pdf) or a MicrosoftWord document (*.doc), select Create link to Blackbaud
NetCommunity document and browse to the document to link.

• To remove an existing link from the part, select Remove Existing Link.
3. To open the linked page or document in a separate window, enter a name for the window in

the Open in another window named field.

Tip: To display multiple linked pages or documents in the same separate window, enter the same
window name in the Open in another window named field for each link to open in the window.

4. Click OK. You return to the Edit Part screen.

ConstituentCodes
A constituent code tells you why a constituent is in your database. For example, you select a
constituent code from The Raiser's Edge, such as Friend, to associate with users who donate on your
website. You can select additional constituent codes from The Raiser's Edge to associate with other
constituents, such as Event Participant or Volunteer. This way, when a user submits data on your website
for processing to The Raiser's Edge, you efficiently track the reason each constituent is in your
database.

In the program, there are two ways to download constituent codes.
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• You can select constituent codes for new constituents in NetCommunity Options. After a
transaction is processed, these constituent codes automatically apply to new constituent records.

• When you create certain part types, you can select to associate a constituent code with the part.
When the website user submits data for the part, the constituent code defaults in the transaction.

Automatically Apply Constituent Codes
From Options on the NetCommunity page, when you select a constituent code for New Constituents,
the constituent code downloads automatically to The Raiser's Edge for all new constituent records
processed from the program. The code does not download to existing constituent records.

Tip: Selecting a constituent code for New Constituents is optional. In The Raiser's Edge, to query on
new records created from the program, we recommend you select a constituent code in New
Constituents.

If you select a constituent code for the Matching Gifts option, the constituent code downloads
automatically to The Raiser's Edge for all new organization records processed from a matching gift
donation.

Constituent CodesOn aTransaction screen
From the NetCommunity page in The Raiser’s Edge, the Sign-Up Requests, Donations, Volunteer
Requests, and Event Registrations transaction types include a constituent code field. The constituent
code in the field defaults in both new and existing records in The Raiser’s Edge.
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The constituent code in this field defaults from the Constituent Code field on the Edit Part screen in
Parts. For example, Online is the constituent code for Donations transactions. When the Donation Form
part was created, Online was selected in the Constituent Code field.

Tip: If the constituent code on the transaction screen is the same code as the New Constituents
constituent code, the code is not duplicated on the Bio 2 tab in the constituent record in The Raiser’s
Edge. If the constituent codes are different, both codes download to the new constituent record.

You can download the constituent code to an offline constituent record. You can also select a different
constituent code for the constituent. To prevent the constituent code from downloading to The
Raiser's Edge, delete the code from the field.

Constituent Codesand Part Types
Review the following information for details about the Constituent Code field on various part types in
the program.

• User Login — The code applies to new and existing constituent records and is specific to each
User Login part. For example, you can create separate login parts for subsites you create, such as
multiple chapters. The constituent code for a login part may be Atlanta Member.

The constituent code you select for this part defaults to the Transaction Constituent Code frame in
Sign-up Requests on the NetCommunity page in The Raiser’s Edge for processing. The code
selected for New Constituents in Blackbaud NetCommunityOptions also downloads to The Raiser’s
Edge for new constituents. However, if the constituent code on the User Login part and in New
Constituents is the same, the code is not duplicated on the record in The Raiser’s Edge.
• Donation Form — The constituent code applies to new and existing constituents.

This is the same for the donation steps in a Personal Page Manager and a Fundraiser part.

• Event Registration Form — The constituent code applies to new and existing event registrants.

• Fundraiser — This part contains two Constituent Code fields. The first field, located on the Step 2:
Fundraiser Options screen, downloads automatically to new and existing records in The Raiser's
Edge. This constituent code is typically used if you consider the fundraiser participant constituency
to be different than a regular Blackbaud NetCommunity user constituency.

These constituent codes do not appear in the Fundraiser transaction on the NetCommunity page in
The Raiser’s Edge. However, after you process the transaction, they appear automatically on the Bio 2
tab in the constituent record.

The second Constituent Code field, located on the Step 6: User Login Form screen, applies to users
who register for the Fundraiser that are not yet members of your site. This constituent code defaults
to the Transaction Constituent Code frame on the Sign-up Requests transaction on the
NetCommunity page in The Raiser’s Edge.

This is the same for the two Constituent Code fields in a Personal Page Manager part. The first field
is on the Step 1: Personal Page Options and Administrator Roles screen. The second field is on the
Step 2: User Login Form screen for a Personal Page Manager. It applies to users who sign up using
the personal page registration.

• Membership Form — The constituent code applies automatically to new and existing constituent
records. This includes members or gift of membership recipients. This constituent code does not
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appear in the Memberships transaction on the NetCommunity page in The Raiser’s Edge. However,
after you process the transaction, it appears on the Bio 2 tab in the constituent record.

• Volunteer Opportunity — The constituent code downloads for volunteers who sign up for a job
online. The code applies to existing constituent records.

35 CHAPTER 1




